Работа оптопорта Карат-307 

Логин:
  Пароль:
Обычный
Безопасный
Запомнить пользователя



Зарегистрироваться
Забыли пароль?
 
 
 
Форум Теплопункта »   Приборы учета »   КАРАТ »   Работа оптопорта Карат-307
RSS

Работа оптопорта Карат-307

Оптопорт то работает, то не работает, то снова работает...

<<Назад  Вперед>>Страницы: 1 * 2
Печать
 
Василий Кузнецов
Долгожитель форума


Всего сообщений: 3084
Ссылка


Дата регистрации на форуме:
28 июня 2011

Василий Кузнецов написал:
[q]
В чём дело? Что мешало работать оптопорту на объекте?
[/q]

Продолжение истории.

Вернул вычислитель на объект и снова оптопорт перестал работать. Начал экспериментировать, выключил на объекте подаваемое на него напряжение и оптопорт заработал. Снова включил - опять не работает.

Вот такая вот странная закономероность вырисовывалась.
А напряжение, которое на него подавалось - 24,6В от блока питания 10ВР220-24Д....
Дмитрий Анисимов
Администратор

Дмитрий Анисимов
Откуда: Верхняя Салда
Всего сообщений: 8033
Ссылка


Дата регистрации на форуме:
1 мар. 2008
У меня все 307е запитаны "снаружи" (через коммуникаторы). Оптопорты работают.

Дмитрий Анисимов
Администратор

Дмитрий Анисимов
Откуда: Верхняя Салда
Всего сообщений: 8033
Ссылка


Дата регистрации на форуме:
1 мар. 2008
Удивительное совпадение: я сегодня сам столкнулся с тем же самым!!!

У меня 307е подключены через коммуникаторы, но чуть больше года назад, когда я обходил эти узлы впервые и делал настройки, то все КАРАТы опрашивал пультом. И они работали все, кроме, кажется, одного, но там была конкретная и позднее вылеченная неисправность. С тех пор приходилось (и, увы, не раз) некоторые 307е снова посещать с пультом. И тоже всегда все читалось - при подключенных коммуникаторах = внешнем электропитании.

А сегодня снова пришлось посетить один узел, на котором не был больше года, т.к. здесь связь через коммуникатор работала прекрасно. Прихожу, достаю пульт, прикладываю, нажимаю - прибор не найден! Пробую еще раз, еще - результат тот же. И тут вспоминаю сообщение Василия Анатольевича! Отключаю внешнее питание, снова прикладываю оптоголовку - прибор найден, архивы "сняты"!

Сразу отмечу: известно, что оптопорт недоступен, если в это время идет передача данных через RS485. Но здесь коммуникатор хоть и был вначале подключен, во время неудачных попыток "съема" пультом он был не в сети.

И еще: я на этот объект приехал именно из-за того, что 3 дня назад пропала связь через коммуникатор. Так вот, судя по миганию светодиодов, информации на дисплее 307го и логу обмена на сервере ситуация стала следующей: коммуникатор регистрируется в сети, обменивается служебными данными с 307м (уровень сигнала - 90%, кстати - и баланс); соединяется с сервером; сервер присылает запрос, 307й или не отвечает сразу, или отвечает на первый запрос и все. Как будто порт RS485 отрубается. Т.е. перестал работать при внешнем электропитании оптопорт и одновременно возникли проблемы со связью через коммуникатор.

Василий Кузнецов
Долгожитель форума


Всего сообщений: 3084
Ссылка


Дата регистрации на форуме:
28 июня 2011

Дмитрий Анисимов написал:
[q]
Т.е. перестал работать при внешнем электропитании оптопорт и одновременно возникли проблемы со связью через коммуникатор.
[/q]

Можно сделать вывод, что проблемы со связью возникают только по RS-485, т.к. в моих двух случаях данные через USB снимались без проблемм.
Василий Кузнецов
Долгожитель форума


Всего сообщений: 3084
Ссылка


Дата регистрации на форуме:
28 июня 2011

Дмитрий Анисимов написал:
[q]
Т.е. перестал работать при внешнем электропитании оптопорт и одновременно возникли проблемы со связью через коммуникатор.
[/q]

И ещё можно сделать вывод, что отказ оптопорта и RS-485 может быть не связан с внешним воздействием через выходную цепь RS-485, т.к. в моём случае к интерфейсу RS-485 никто ничего не подключал.
Дмитрий Анисимов
Администратор

Дмитрий Анисимов
Откуда: Верхняя Салда
Всего сообщений: 8033
Ссылка


Дата регистрации на форуме:
1 мар. 2008
Обнаружил среди своих подопечных еще один КАРАТ, не передающий данные через оптопорт при включенном внешнем (через коммуникатор) питании! После этиого специально заехал в соседний дом, проверил - там КАРАТ с питанием через коммуникатор передает через оптопорт, как положено.

При этом наметилась (статистики пока мало) следующая тенденция: сначала начинаются сбои при передаче данных через коммуникатор (при нормальном уровне сигнала), затем "пропадает" передача через оптопорт при внешнем питании.
Дмитрий Анисимов
Администратор

Дмитрий Анисимов
Откуда: Верхняя Салда
Всего сообщений: 8033
Ссылка


Дата регистрации на форуме:
1 мар. 2008
Новый случай: 307й перестал передавать данные через коммуникатор. Коммуникатор на связь выходит (режим GPRS 2), но прибор на запросы не отвечает. Я приехал на объект и не смог прочитать архивы пультом. Т.е. у 307го умер RS485 (на коммуникаторе светодиод "Прибор" красный", связи с прибором по 485 нет), и перестал работать оптопорт. Не работает ни при внешнем, ни при батарейном питании.
Василий Кузнецов
Долгожитель форума


Всего сообщений: 3084
Ссылка


Дата регистрации на форуме:
28 июня 2011

Дмитрий Анисимов написал:
[q]
Не работает ни при внешнем, ни при батарейном питании.
[/q]

А если подогреть до комнатной температуры и положить в чёрный ящик? :)
Дмитрий Анисимов
Администратор

Дмитрий Анисимов
Откуда: Верхняя Салда
Всего сообщений: 8033
Ссылка


Дата регистрации на форуме:
1 мар. 2008
Он и так в тепле и в темноте. :cool:
tehnik
Новичок


Всего сообщений: 15
Ссылка


Дата регистрации на форуме:
12 янв. 2016
<<Назад  Вперед>>Страницы: 1 * 2
Печать
Форум Теплопункта »   Приборы учета »   КАРАТ »   Работа оптопорта Карат-307
RSS


Время выполнения скрипта: 0.0624. Количество выполненных запросов: 18, время выполнения запросов 0.0245




 


IntB Beige Style © Fisana